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Introduction and Prerequisites 

ez2update Australia 
ez2update Australia is part of a suite of software products we have developed to make Australia's 
electricity market understandable.  

ez2update Australia provides a fast and reliable feed of Australian National Electricity Market (NEM) 
data from AEMO, ElectraNet, TransGrid, AusNet Services, and Powerlink.  

ez2update Australia is server side software that pulls data over the internet from our servers, and 
writes this data into your own local database.  The ez2update Australia database contains a set of 
tables for each data set that you license, installed into an SQL Server or Oracle instance. 

ez2update Australia works in conjunction with global-roam’s leading edge viewing platform, 
ez2view, which reads data from the ez2update Australia database, and displays the information in 
an intuitive dashboard format. 

This manual describes how to install ez2update Australia as either an upgrade to a previous version, 
or as a clean installation. 

This manual applies to ez2update Australia version 5.5 or later. 

What you will need to do 
The tasks involved in this deployment include such things as installation and configuration of a 
database and configuration of proxy settings. 

To successfully install or upgrade ez2update Australia you will need: 

 Intermediate IT skills. 
 Basic knowledge of Microsoft SQL Server or Oracle. 
 Your GR-ID and password. 
 Access to a user account with administrative permissions. 
 Knowledge of any proxy settings or other internet security processes in place in your 

organization. 
 Access to the internet. 

For each of the global-roam products that you install or upgrade, you will need to go through the 
following steps: 

1. Installation of the software 
2. Configuration of Proxy settings  
3. Activation of your software license  
4. Configuring a connection to the database  
5. Install databases and tables 
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Supported Platforms and System Requirements 

Operating Systems 
ez2update Australia is officially supported on the following platforms: 

 Windows 7 SP1 
 Windows 8.1 
 Windows 10 
 Windows Server 2012 R2 
 Windows Server 2016 
 Windows Server 2019 

ez2update Australia will likely work on other Windows platforms that support the .NET framework 
4.8 - please let us know how you get on... 

Database 
ez2update Australia requires either Microsoft SQL Server or Oracle. The following versions are 
supported: 

 Microsoft SQL Server 2012 and above 
 Oracle 12c and above 

.NET Framework 
ez2update Australia requires the .NET Framework 4.8.  You must have the .NET Framework 4.8 
installed beforehand or the installer will fail to install and display an error message. 

File System Access 
ez2update Australia will create and write to a number of folders under the following locations: 

ProgramData/global-roam 

Hardware Requirements 
ez2update requires the following hardware: 

 Processor: Pentium III-compatible processor or faster; 2.0 GHz or faster. 
 Disk Space: 620 MB free disk space. This assumes that the .NET prerequisites are already 

installed on the target machine.  This does not include data stored in the database. 
 Memory: 4 GB RAM or more (recommended 6 GB) 

Database Population 
During the setup of ez2update, the application will download some historical data (one time per 
installation only) and backfill the database. This initial database population will consume 
approximately 250 MB of network downloads from the global-roam servers, which will translate into 
approximately 8,500 MB of data in the database on disk. 
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After the initial setup, ez2update will download data at a rate of approximately 2 to 3 MB of network 
bandwidth per hour, which will translate into approximately 2.5 to 3 GB of data in the database per 
day. 

To prevent uncontrolled growth in the size of the database, ez2update is accompanied by a 
Maintenance script that should be deployed according to the instructions in the section Installing 
the , on page 23. 
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Network Requirements 
ez2update Australia downloads data from global-roam servers over the Internet. Additionally, 
ez2update requires access to internet for license verification and configuration purposes. 

We recommend that you allow firewall access using our domain name rather than by IP 
address as we cannot guarantee that our IP addresses are static. 

To simplify firewall configuration for future ez2update upgrades we recommend that you 
allow firewall access for the entire domain. 

*.datastripe1.com 

The specific URL's that ez2update will require access to are: 

URL Description Available Port 
https://gridlicensing.datastripe1.com License verification 443 
https://configurationservice.datastripe1.com Configuration service 443 
https://ez2update.datastripe1.com Data service 443 
https://ez2update.datastripe2.com Data service 443 
https://ez2update.datastripe3.com Data service 443 

 

You will need to ensure that you have permitted the use of the SSL certificate that we have 
configured for the URLs listed. 

Database Tables 
ez2update Australia will populate your database with data from a subset of the AEMO MMS Data 
Model. If you require documentation on the structure of the tables for your own analysis, please 
refer to the AEMO documentation for the MMS Data Model available from the AEMO website.  The 
MMS tables that are populated by ez2update are as follows: 

BIDDAYOFFER INTERCONNECTOR PARTICIPANTCLASS 
BIDDAYOFFER_D INTERCONNECTORCONSTRAINT PREDISPATCHCASESOLUTION 
BIDDUIDDETAILS LOSSFACTORMODEL REGION 
BIDDUIDDETAILSTRK LOSSMODEL PREDISPATCH_LOCAL_PRICE 
BIDPEROFFER MARKET_PRICE_THRESHOLDS PREDISPATCHCONSTRAINT 
BIDPEROFFER_D MARKETNOTICEDATA PREDISPATCHINTERCONNECTORRES 
BIDTYPES MCC_CONSTRAINTSOLUTION PREDISPATCHLOAD 
BIDTYPESTRK MNSP_INTERCONNECTOR PREDISPATCHPRICE 
DISPATCH_LOCAL_PRICE MNSP_PARTICIPANT PREDISPATCHPRICESENSITIVITIES 
DISPATCH_UNIT_SCADA MTPASA_CASESOLUTION PREDISPATCHREGIONSUM 
DISPATCHABLEUNIT MTPASA_CONSTRAINTSOLUTION PREDISPATCHSCENARIODEMAND 
DISPATCHCASESOLUTION MTPASA_INTERCONNECTORSOLUTION REGIONSTANDINGDATA 
DISPATCHCONSTRAINT MTPASA_REGIONAVAIL_TRK SPDCONNECTIONPOINTCONSTRAINT 
DISPATCHINTERCONNECTORRES MTPASA_REGIONAVAILABILITY SPDINTERCONNECTORCONSTRAINT 
DISPATCHLOAD MTPASA_REGIONSOLUTION SPDREGIONCONSTRAINT 
DISPATCHOFFERTRK NETWORK_EQUIPMENTDETAIL STADUALLOC 
DISPATCHPRICE NETWORK_OUTAGECONSTRAINTSET STATION 
DISPATCHREGIONSUM NETWORK_OUTAGEDETAIL STATIONOPERATINGSTATUS 
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DUDETAIL NETWORK_OUTAGESTATUSCODE STATIONOWNER 
DUDETAILSUMMARY NETWORK_SUBSTATIONDETAIL STATIONOWNERTRK 
EMSMASTER P5MIN_CASESOLUTION STPASA_CASESOLUTION 
GENCONDATA P5MIN_CONSTRAINTSOLUTION STPASA_CONSTRAINTSOLUTION 
GENCONSET P5MIN_INTERCONNECTORSOLN STPASA_INTERCONNECTORSOLN 
GENCONSETINVOKE P5MIN_LOCAL_PRICE STPASA_REGIONSOLUTION 
GENCONSETTRK P5MIN_REGIONSOLUTION TRADINGINTERCONNECT 
GENERICCONSTRAINTRHS P5MIN_UNITSOLUTION TRADINGLOAD 
GENERICEQUATIONDESC PARTICIPANT TRADINGPRICE 
GENERICEQUATIONRHS PARTICIPANTCATEGORY TRADINGREGIONSUM 
GENUNITS PARTICIPANTCATEGORYALLOC TRANSMISSIONLOSSFACTOR 
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Contacting Global-Roam 
If you experience difficulties in installing or upgrading ez2update Australia, please feel free to 
contact us at:  

e-mail: support@global-roam.com 

phone: +61 7 3368 4064 
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Installing ez2update for the First Time 
Question: Will you be using Oracle or SQL Server for your database backend? 

If the answer is “Oracle”, go to the section Using Oracle to hold your ez2update Database, on page 
10. 

If the answer is “SQL Server”, go to the section Using SQL Server to hold your ez2update Database, 
on page 11. 
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Using Oracle to hold your ez2update Database 
You’re here because you already have an Oracle instance to use, probably managed by an Oracle 
DBA. Now would be a good time to talk to them, assuming you haven’t already. 

ez2update Australia uses self contained managed libraries to connect to Oracle, there is not need for 
local Oracle driver libraries to be pre-installed. 

Make a note of the details to connect to your Oracle instance (machine, instance name and 
username/password to use). 

Proceed to Installing ez2update Australia, on page 12.  
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Using SQL Server to hold your ez2update Database 
Question: Do you already have an existing instance of SQL Server that you can use for the ez2update 
Australia Databases? 

If “Yes”, you can skip this section! Make a note of the SQL Server instance location 
(MACHINENAME\INSTANCENAME) and a Username and Password combination that you will be 
using. Go to the next section Installing ez2update Australia, on page 12. 

If “No”, keep reading. 

We recommend that you install SQL Server 2019 Express, which is a free database server provided 
by Microsoft.  

Download SQL Server 2019 Express from Microsoft Sql Server Downloads.  

 Make sure you install the version appropriate for your operating system. 
 Also, make sure that you download both the database and the management tools. 

Run the installer for SQL Server Express.   

These instructions assume you use the default name for the database instance which is 
“SQLEXPRESS”. 

 During the install of SQL Server Express, you will be prompted an authentication mode.  We 
recommend that you select "SQL Authentication Mode".  You will also be prompted to create an 
account for connecting to the database. We recommend that you create an account specifically 
for ez2update Australia to access the database.  This account must have read/write access to the 
database.   

Run the installer for the SQL Server Management Tools. 

Having run the installers, run the "SQL Server Configuration Manager" to check that the install 
worked. You can find the SQL Server Configuration Manager through the Windows Start menu under 
[Programs - Microsoft SQL Server - Configuration Tools]. 

 Use the SQL Server Configuration Manager to make the SQL Server instance accessible over your 
network. To do this, select [SQL Server Network Configuration -> Protocols for SQLEXPRESS] 
from the panel on the left hand side of the screen, and enable at least TCP/IP. 

 NOTE: To access your SQL Server instance over the network you may also need to open up TCP 
ports appropriately in your firewall to the host machine. The default SQL Server port is 1433. 

You can now continue on the next section - Installing ez2update Australia.  
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Installing ez2update Australia 
Make sure you have the details for connecting to whatever database backend you will be using 
(Oracle or SQL Server). 

ez2update Australia should be installed on a stable machine, one with high availability (on all the 
time, does not regularly get restarted). Desktops and laptops are not usually appropriate for 
ez2update Australia (there’s nothing stopping you from installing the ez2update Australia on them, 
but do it at your own peril). 

Installation 
Download the install file for ez2update Australia from the download section of the ez2view Australia 
web site (go to http://install.ez2viewaustralia.info and follow the links to the ez2update Download 
page). 

Right-click the install file and choose the “Run As Administrator” option, then follow the prompts 
until the installation has completed. 

You will need to make sure you have the .NET Framework 4.8 installed beforehand. 

Once the installation has completed, you should be able to see an icon for ez2update Australia on 
your desktop. Additionally, there will be Windows Service installed called “ez2update Australia”. 

The Windows Service will be installed with default login details. Following the install, confirm that 
these logon details are set to a user who has access to the internet and to the Oracle/SQL Server 
instance that you have chosen (ez2update Australia requires access to the internet and to its 
database at all times). 

Configuration 
Double-click on the ez2update Australia Service shortcut on the desktop. A mostly gray screen with a 
simple menu in the top left corner. Make the following menu selection: 

File -> Application -> Start 

Proxy Setup 
ez2update Australia requires access to internet to retrieve data from the Global-Roam servers. For 
more details on the specific URLs go to the section on Network Requirements. 

If ez2update Australia has experienced a problem with connecting to any of the websites above 
during startup, it will display the Proxy Settings screen. It looks like this: 
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If you do not use a proxy to access the internet, simply click OK. 

If you do use a proxy, then we suggest that you maintain your proxy information in your system 
settings. If you make sure the [Use System Settings] option is checked on the Proxy Settings screen, 
then your system settings should automatically be detected and used in ez2update Australia. 

If you have difficulties with ez2update Australia with regards to internet access, you may need to 
manually specify your proxy settings and credentials. This can be done on the Proxy Settings screen. 

NOTE: The Proxy Settings screen is also available from inside the application at [Tools -> Internet 
Settings]. This option is only available when ez2update Australia is running as an Application, this 
option will not be available if ez2update Australia is running as a Service. 

NOTE: The ez2update Australia service is installed by default under the Local Service account. If your 
proxy requires authentication, then this account will not work. To resolve this, run the ez2update 
Australia Service under a domain account that does have the ability to authenticate to the proxy. 

License Activation 
On first startup, ez2update Australia will display a screen saying that “This machine does not have a 
license for ez2update Australia”. 

Simply follow the instructions on the screen to configure a license for ez2update Australia (it mostly 
involves entering information/selecting options and clicking next). 

If you do not have any licenses to select on Step 3, and you believe that you should have a full 
commercial license, then you will need to go to https://www.global-roam.com/secure to manage 
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your licenses before you can go any further. After you login to the website, click on My Licenses 
(top-right corner). On this page you can manage your licenses. If you didn’t have a license available 
in Step 3, you may need to deactivate one of your existing licenses to free it up for use. 

You cannot start ez2update Australia without a valid license. 

Database Setup 
On first startup, ez2update Australia will display a screen called “Data Source Setup”. This screen is 
the database settings screen. It will allow you to point ez2update Australia at the database that it 
needs to update. On first startup, it will look something like this: 

 

There are 5 possible database connections. You may only have a subset of the total list of database 
connections available in your copy of ez2update Australia. 

The 5 possible database connections are: 

 TransGrid Database Connection 
 SPAusNet Database Connection 
 Electranet Database Connection 
 Powerlink Database Connection 
 NEM Data Database Connection 

For each of the database connections that you have, please use the section Configuring a Database 
Connection, on page 15. 
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Configuring a Database Connection 
A database connection is the location where ez2update Australia stores all of the data for a data set 
that it downloads. To configure a Database Connection, from the database settings screen 

 Select the Database Connection you want to configure 
 Click the Configure Selected button. 

On the next screen, select either [DATASET]_MSSQL, or [DATASET]_ORACLE (where DATASET is the 
name of the data set you are configuring, i.e. NEMData, SPAusNet or any one of the others) in the 
drop-down box at the top, and click the New button. 

If you are using SQL Server, go to the section SQL Server Specific, on page 16. 

If you are using Oracle, go to the section Oracle Specific, on page 20. 
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SQL Server Specific 
Fill the next screen in with information about how to connect to the database where you want to 
install the tables for the data set.  

 

Note:  

If you cannot find your SQL Server in the server drop down box, you can simply type in the name of 
the machine that it is on, followed by a “\” character, followed by the instance name. e.g. 
MACHINE_NAME\INSTANCE_NAME. 

Once you have filled out the name, server and authentication, it’s time to install the tables necessary 
for the data set you are configuring. 

We suggest that you install all tables (for all data sets) into a single SQL Server database. If this is the 
first time you are running through the Configuring a Database Connection section, then you should 
go to the section Creating a new SQL Server Database, on page 17. If you have previous created an 
SQL Server database to use for all your ez2update data set tables, go to the section Installing the 
tables into an existing SQL Server Database, on page 18. 
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Creating a new SQL Server Database 
Use the ”Database on Server” drop down box to select the “<Install New Database>” option and 
then click on the “Install Database” button. 

Enter the name for the database where you want to tables for the data set installed. If the default 
name is fine, simply click OK. If you enter something different write it down for later. 

After the script has finished executing, you will be returned to the Create MSSQL Connection String 
screen. Click on the “Test Connection” button to verify that all is well, then click OK. 

Go to the section Done with Database Connection Configuration, on page 19. 

  



18 
 

 

Installing the tables into an existing SQL Server Database 
Use the ”Database on Server” drop down box to select the name of the database that you previously 
created for the purpose of holding tables for the ez2update Australia data sets. 

After the script has finished executing, you will be returned to the Create MSSQL Connection String 
screen. Click on the “Test Connection” button to verify that all is well, then click OK. 

Go to the section Done with Database Connection Configuration, on page 19. 
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Done with Database Connection Configuration 
If you need to configure another database connection, go back to Configuring a Database 
Connection, on page 15. 

If you are done, go to Done with Database Setup, on page 21.  
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Oracle Specific 
Fill the next screen in with information about how to connect to the Oracle database where you 
want to install the tables for the data set. 

 

Once you have filled out the name, server and authentication, click on the “Test Connection” button. 
It will ask you if you want to install the database tables. Select “Yes” (you can also click on the 
“Install Database” button and the same thing will happen). 

Once the script has finished executing, click “Test Connection” to verify that all is well, then click OK. 

If you need to configure another database connection, go back to Configuring a Database 
Connection, on page 15. 

If you are done, go to Done with Database Setup, on page 21.  
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Done with Database Setup 
You should be back at the main database settings screen. It should now look something like this 
(remember that you may not have all the connections shown here): 

 

Note that all the Database Connections say “Valid” next to them (this means it’s all set up and ready 
to go). 

Click Done. 

Note:  

If you need to change your database settings after setting them up initially, you can access the Data 
Access Manager using the top-level menu. Before modifying the connection string you should stop 
ez2update (either Application or Service) using the File menu option. 

Tools -> Database Connection Strings 

For the new settings to take effect, ez2update will request t restart. 
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Done with Configuration 
At this point, your copy of ez2update is all configured and ready to go. In fact, after you dismissed 
the last configuration dialog, it should have already started doing things. 

Done with ez2update Australia 
At this point your updater should be showing a list of file types, and the last times that a file of that 
type was downloaded and processed. 

Please leave ez2update Australia to run until it has finished populating the database for the first 
time. This may take an hour or so, depending on the speed of your machine.  

Once the population has run for about an hour, you can safely go to File -> Application -> Stop, and 
then go to File -> Service -> Start in order to set ez2update Australia to run completely 
autonomously. You can safely close the Updater Interface at this point, and it will continue to work 
in the background as a Windows Service. 

If you cannot see at least some activity, or if you do not have any files appearing at all, or you see red 
errors, something is wrong, and ez2update Australia is probably not working. If this is the case, 
please contact global-roam. 

Go to the section Installing the  script, on page 23. 
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Installing the Maintenance Script 
The maintenance script is a small SQL Script set to run automatically at regular intervals, to keep the 
size of the ez2update Australia database relatively small.  This section provides instructions for 
setting up a Windows Scheduled task to run this maintenance script at regular intervals.  You will 
need to download the script and place it in a well known folder that is accessible to the Scheduled 
Task. 

Download the maintenance script for ez2update Australia from the download section of the ez2view 
Australia web site (go to http://install.ez2viewaustralia.info/ and follow the links to the Download 
page). 

Set up a new Windows Scheduled Task – if you need to, please consult the Windows Help system to 
find out how to establish a Scheduled Task on your operating system. 

The Scheduled Task should be set up to run a command line as follows: 

sqlcmd.exe -S [SERVER_NAME] -U [USERNAME] -P [PASSWORD] -i [PATH TO SCRIPT] 

where the following are the arguments: 

 SERVER_NAME is the fully qualified address of the SQL Server that the ez2update Database is 
installed on (MACHINENAME\INSTANCENAME) 
 

 USERNAME is a user account in the specified SQL Server with delete permissions on the 
ez2update Database 

 
 PASSWORD is the SQL Server password for the above USERNAME 

 
 PATH_TO_SCRIPT is the full path to the Maintenance script file that you downloaded above 

Note that sqlcmd.exe is typically located in  

C:\Program Files\Microsoft SQL Server\[VERSION]\Tools\Bin. 

Pick the latest version if there are multiple. 

Schedule this task to occur every day (once every 24 hours) at midnight. 

Note – Dataset Configuration 
If you do not have access to all of the datasets available through ez2update Australia, then you will 
need to edit the maintenance script to remove the sections that deal with the datasets that you do 
not have. 

Inside the script, each section that deals with a dataset is labeled as follows. 

BEGIN [DATASET] Table Maintenance 

[Script for deleting table data] 
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END [DATASET] Table Maintenance 

Note – Database Location 
The ez2update Australia Maintenance script supports a different database location for each of the 
data sets that the application updates (NEMData, Electranet, Powerlink, SPAusNet and Transgrid). 

It is possible that the databases that contain the tables required for the data sets above are not 
named the same as the default names (the default names are listed above). If this is the case, then 
you need to find the appropriate entry in the script, and change it to your database name. 

The entry will look like this: 

USE DATABASE_NAME 
GO 

For example, if you have installed the tables required for the Electranet data set (the 
Electranet_Data table) into a database called ‘ez2update Australia’ then you will need to change the 
line: 

USE ELECTRANET 

to  

USE [EZ2UPDATE AUSTRALIA]  

It is important to include the square brackets if there is a space in your database name, otherwise 
they are optional. 

It is possible to install the set of tables required for each of these data sets to the same database. If 
this is the case, then you will need to remove the redundant  

USE DATABASE_NAME 

entries throughout the script. 

Make sure that the first  

USE DATABASE_NAME 

entry at the top of the script still exists however, and that it points to the correct database name 
(the one with all your tables in it). 

Note – Customized Maintenance 
You can customize the amount of data that the script will delete by changing the values of various 
variables in the script. By default, the script will: 

Variable Default 
Hours 

Tables 

@HOURS_OF_PREDISPATCH_TO_KEEP 48 PREDISPATCHCASESOLUTION 
PREDISPATCHCONSTRAINT 
PREDISPATCHLOAD 
PREDISPATCHPRICE 
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Variable Default 
Hours 

Tables 

PREDISPATCHPRICESENSITIVITIES 
PREDISPATCHREGIONSUM 
PREDISPATCHINTERCONNECTORRES 

@HOURS_OF_P5MIN_TO_KEEP 48 P5MIN_CASESOLUTION 
P5MIN_CONSTRAINTSOLUTION 
P5MIN_REGIONSOLUTION 
P5MIN_INTERCONNECTORSOLN 
P5MIN_UNITSOLUTION 

@HOURS_OF_DISPATCH_TO_KEEP 48 DISPATCHCASESOLUTION 
DISPATCHCONSTRAINT 
DISPATCH_UNIT_SCADA 
DISPATCHCONSTRAINT 
DISPATCHINTERCONNNECTORRES 
DISPATCHLOAD 
DISPATCHPRICE 
DISPATCHREGIONSUM 
ELECTRANET_DATA 
POWERLINK_DATA 
SPAUSNET_DATA 
TRANSGRID_DATA 

@HOURS_OF_TRADING_TO_KEEP 168 TRADINGLOAD 
TRADINGPRICE 
TRADINGINTERCONNECT 
TRADINGREGIONSUM 
TRADINGINTERCONNECT 

@HOURS_OF_MARKETNOTICEDATA_TO_KEEP 168 MARKETNOTICEDATA 
@HOURS_OF_STPASA_TO_KEEP 168 STPASA_CASESOLUTION 

STPASA_CONSTRAINTSOLUTION 
STPASA_INTERCONNECTORSOLN 
STPASA_REGIONSOLUTION 

@HOURS_OF_MTPASA_TO_KEEP 672 MTPASA_CASESOLUTION 
MTPASA_CONSTRAINTSOLUTION 
MTPASA_INTERCONNECTORSOLUTION 
MTPASA_REGIONAVAILABILITY 
MTPASA_REGIONAVAIL_TRK 
MTPASA_REGIONSOLUTION 

HOURS_OF_BIDDATA_TO_KEEP 48 BIDDAYOFFER 
BIDDAYOFFER_D 
BIDPEROFFER 
BIDPEROFFER_D 
DISPATCHOFFERTRK 

 

Note – Oracle Maintenance 
We do not currently provide a maintenance script for Oracle. Feel free to use this SQL Server script 
as a base, and work from there (or create your own script from scratch). It is probably a good idea to 
set up some sort of reaping however, as the data tables can get quite large over time. 
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Done Installing for the First Time 
If you got to this point, then everything probably went well, and you’re all set up. Awesome! 

If you have any problems at all, please contact global-roam. 
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Upgrading an Existing Installation 
This section describes the steps for upgrading an existing installation of ez2update Australia. 

Upgrading from an earlier version of ez2update Australia to the latest version is mostly painless. 
Please follow the instructions below. 

Upgrading ez2update Australia 

Installation 
Download the install file for ez2update Australia from the download section of the ez2view Australia 
web site (go to http://install.ez2viewaustralia.info/ and follow the links to the Download page). 

If you do not already have the .NET Framework 4.8 installed, you will need to download and install 
that first. 

Right-click the install file and choose the “Run As Administrator” option, then follow the prompts 
until the installation has completed. 

Once the installation has completed, you should be able to see an icon for ez2update Australia on 
your desktop. Additionally, there will be Windows Service installed called “ez2update Australia”. 

The Windows Service will be installed with default login details. Following the install, confirm that 
these logon details are set to a user who has access to the internet and to the Oracle/SQL Server 
instance that you have chosen (ez2update Australia requires access to the internet and to its 
database at all times). 

Upgrading the ez2update Australia Databases 
After you have upgraded the ez2update Australia application, you may need to upgrade the 
ez2update Australia database to include new tables. 

To do this you will need to run in application mode at which point ez2update Australia will detect if 
your current database is an older version than it expects and will prompt you to upgrade the 
database. If you elect not to upgrade the database at this point, you will be presented with the 
database configuration dialog from which you can select a different database or cancel to exit the 
application.  

Configuration 
Because you upgraded from a previous version of ez2update Australia, no additional configuration 
should be necessary. 

Use the shortcut on the desktop (or in the Start Menu) to open ez2update Australia, and click File -> 
Application -> Start. 
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Done with Upgrading ez2update Australia 
At this point your updater should be showing a list of file types, and the last times that a file of that 
type was downloaded and processed. 

After a few minutes, you can safely go to File -> Application -> Stop, and then go to File -> Service -> 
Start in order to set ez2update Australia to run completely autonomously. You can safely close the 
Updater Interface at this point, and it will continue to work in the background as a Windows Service. 

If you cannot see at least some activity, or if you do not have any files appearing at all, or you see red 
errors, something is wrong, and ez2update Australia is probably not working. If this is the case, 
please contact global-roam. 

Go to the section Configuring Database Maintenance, on page 29. 
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Configuring Database Maintenance 
Global-roam provides a small SQL Script which can be set to run automatically at regular intervals, to 
keep the size of the ez2update Australia Database relatively small. This script is commonly known as 
“The Maintenance script”. It is only available for MSSQL Server installations (for a note about Oracle, 
see the end of this section). 

Question: Have you previous installed the Maintenance script to maintain the size of your ez2update 
Database? 

If you don’t know whether or not you have previously installed the Maintenance script, check 
the Windows Scheduled Tasks on the computer where ez2update Australia is installed, and 
look for a task that uses sqlcmd to run a local sql script on the ez2update Australia database 
server. 

If you answered yes, then go to the section Upgrading the , on page 30. 

If you answered no, then go to the section Installing the  script on page 23. 
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Upgrading the Maintenance script 
It is possible that you have an older version of the Maintenance script. Go to the location where you 
placed the Maintenance script during installation, open the 
“ez2Update_Australia_Maintenance_vxx.sql” file, and check the top for the script version. Note 
down this version number. 

Download the Maintenance script for ez2update Australia from the download section of the 
ez2update Australia web site (go to http://install.ez2viewaustralia.info/ and follow the links to the 
Download page). 

Compare the two version numbers. If the script you downloaded has a higher version number that 
your local copy, then replace your local copy with the one that you downloaded. 

That’s it, you’re upgraded to the latest version of the Maintenance script. 

Note – Script Customizations 
If you have previously customized your Maintenance script in any way, be careful simply overwriting 
the old script with the newer one. We recommend making a copy of the old script file before 
overwriting it, and then double checking for any customizations.  Please read the notes under the 
next section to see which customizations may have taken place. 

 


